Building Autopsy on Fedora

Any Autopsy specific discussions, events, module releases, that don't fall into the other categories.

Moderator: carrier

Building Autopsy on Fedora

Postby slippery60 » Thu Jul 07, 2016 2:28 pm

I'm trying to build Autopsy on Fedora 23. The other thread is for Ubuntu. I've gleaned as much as I think I can from that thread. Thanks Guys.

The process I've followed so far, started with git clone of Autopsy.
as a note, I have had to be root for many of the steps, where I didn't expect to be root.

I have installed:
libaff, (installed but not recognized by ./configure)
and more.

I compiled sleuthkit using the ./compile; make; make install process. It worked fine.
Although I think I had to create a folder for the "../datamodel/Examples with appropriate permissions"

I set the environmental variables:
JDK_HOME, (e.g. /usr/java/jdk1.8.0.92 )
TSK_HOME, (e.g. /home/slippery/git/sleuthkit version -4.2.0)
JAVA_HOME (e.g. /usr/java/jdk1.8.0.92 )

Initially, I used the process described BUILDING.txt from the autopsy git clone.

2a) "see win32\BUILDING.txt in the TSK package for more information." (how to on Visual Studio - I don't have)
"You need to build tsk_jni project. ..." ((note 1) I can't locate a "tsk_jni" project to build)
"Select the Release_PostgreSQL WIN32 or x64 target ..." ( not quite sure how to do this with make..)

item 2b says to
" build the TSK JAR file by typing 'ant dist-PostgreSQL' in bindings/java"
(surprised look on my face. it worked, it hasn't worked before) ( I just re-did TSK using clone not zip of repo)
2c) set the TSK_HOME env variable
2d) do a make install (for windows users)

3) get gstreamer is you are using 32 bit (I'm using 64bit - so this step is not applicable)
4) Get autopsy source - 4A ( not planning on contributing to development. I having problems compiling the stupid
program, I'm not ready to develop)

5a) Tried compiling with netbeans. -
No joy, lots of errors, like:
... package org.sleuthkit.autopsy.coreutils does not exist
... package org.sleuthkit.autopsy.datamodel does not exists

5b) tried compiling without net beans type "ant" in root directory
No joy, again errors, not as many
[nb-javac] ../sleuthkit/autopsy/imagegallery/actions/ error cannot access EventHandler
[nb-javac] ../sleuthkit/autopsy/imagegallery/gui/drawableviews/ error static import
only from classes and interfaces.

Just a few other notes, on things I did to get as far as I have gotten. I extracted several *.jar files (from windows) that were missing and added them in the bindings/java directory where the compilation process said they tried to find the files.

So, I am currently at this point in the compilation process. If any one has thoughts on how to proceed. please provide them.
/ \
|O _ O|
/ \_/ \ ||
.' / \ `. ||
/ _| |_ \ ||
(_/ | | \_) ||
\ / ||
__\_>-<_/__ ||
~;/ \;~ ||
Posts: 1
Joined: Thu Jul 07, 2016 12:04 pm

Return to Autopsy General

Who is online

Users browsing this forum: No registered users and 1 guest