Building autopsy on Ubuntu 14.04.1 [Updated July 2015]

Any Autopsy specific discussions, events, module releases, that don't fall into the other categories.

Moderator: carrier

Re: Building autopsy on Ubuntu 14.04.1 [Updated July 2015]

Postby damelo » Thu Feb 18, 2016 8:20 pm

Hi,

I've got an error when building with ant:

Code: Select all
[ivy:resolve] :: problems summary ::
[ivy:resolve] :::: WARNINGS
[ivy:resolve]       [NOT FOUND  ] org.apache.poi#poi-excelant;3.8!poi-excelant.jar(javadoc) (611ms)
[ivy:resolve]    ==== central: tried
[ivy:resolve]      http://repo1.maven.org/maven2/org/apache/poi/poi-excelant/3.8/poi-excelant-3.8-javadoc.jar
[ivy:resolve]       [NOT FOUND  ] org.apache.poi#poi-scratchpad;3.8!poi-scratchpad.jar(javadoc) (224ms)
[ivy:resolve]    ==== central: tried
[ivy:resolve]      http://repo1.maven.org/maven2/org/apache/poi/poi-scratchpad/3.8/poi-scratchpad-3.8-javadoc.jar
[ivy:resolve]       ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve]       ::              FAILED DOWNLOADS            ::
[ivy:resolve]       :: ^ see resolution messages for details  ^ ::
[ivy:resolve]       ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve]       :: org.apache.poi#poi-excelant;3.8!poi-excelant.jar(javadoc)
[ivy:resolve]       :: org.apache.poi#poi-scratchpad;3.8!poi-scratchpad.jar(javadoc)
[ivy:resolve]       ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve]
[ivy:resolve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS


There is no javavadoc jar in repo1. Any suggestion?

Thanks in advance,

Daniel
damelo
 
Posts: 2
Joined: Thu Feb 04, 2016 1:34 pm

Re: Building autopsy on Ubuntu 14.04.1 [Updated July 2015]

Postby jbrock777 » Thu Mar 17, 2016 12:17 am

Here is a modified version of the earlier script, it works for me on SANS Sift (Ubuntu 14.04) as of 20160316

Code: Select all

#!/bin/bash
workingdir=`pwd`

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install  oracle-java8-installer software-properties-common wget xauth git git-svn build-essential libssl-dev libbz2-dev libz-dev ant automake autoconf libtool vim python-dev gstreamer1.0

export JAVA_HOME="/usr/lib/jvm/java-8-oracle/"
export JDK_HOME="/usr/lib/jvm/java-8-oracle/"
export JRE_HOME="/usr/lib/jvm/java-8-oracle/jre/"
export TSK_HOME=$workingdir/tsk
# Download files / Git Reps
wget -c -O libewf.tar.gz https://github.com/libyal/libewf/releases/download/20150126/libewf-exper...
if [ ! -d sleuthkit ]
then   
   git clone https://github.com/sleuthkit/sleuthkit.git
fi
cd sleuthkit
make clean
git pull
cd ..

if [ ! -d autopsy ]
then
   git clone https://github.com/sleuthkit/autopsy.git
fi
cd autopsy
make clean
git pull
cd ..

# Compile libewf
rm -rf libewf/
mkdir libewf
cd libewf
tar --strip-components=1 -xvzf ../libewf.tar.gz
./bootstrap
./configure --enable-python --enable-verbose-output --enable-debug-output --prefix=$workingdir/tsk
make
make install

# Compile Sleuthkit
cd $workingdir/sleuthkit
./bootstrap
./configure --prefix=$workingdir/tsk --with-libewf=$workingdir/tsk
make
make install

# Build autopsy
mkdir -p $workingdir/tsk/bindings/java/dist
mkdir -p $workingdir/tsk/bindings/java/lib
cp $workingdir/tsk/share/java/Tsk_DataModel.jar $workingdir/tsk/bindings/java/dist/Tsk_DataModel_PostgreSQL.jar

cd $workingdir/tsk/bindings/java/lib
wget -c https://repo1.maven.org/maven2/org/xerial/sqlite-jdbc/3.8.11/sqlite-jdbc...
wget -c http://central.maven.org/maven2/org/postgresql/postgresql/9.4-1201-jdbc4...
wget -c http://central.maven.org/maven2/com/mchange/c3p0/0.9.5-pre3/c3p0-0.9.5-p...
wget -c http://central.maven.org/maven2/com/mchange/c3p0/0.9.5/c3p0-0.9.5.jar
cp $workingdir/sleuthkit/bindings/java/lib/mchange-commons-java-0.2.9.jar $workingdir/tsk/bindings/java/lib/
cd $workingdir/autopsy
ant build




Enjoy.
jbrock777
 
Posts: 1
Joined: Thu Mar 17, 2016 12:12 am

Re: Building autopsy on Ubuntu 14.04.1 [Updated July 2015]

Postby afik » Fri Jun 03, 2016 7:27 am

Hi, I have followed script above but getting this error when creating new case. Any suggestion?

Code: Select all
[exec] INFO [org.sleuthkit.datamodel.SleuthkitCase]: sqlite-jdbc version 3.8.11 loaded in native mode
     [exec] Jun 03, 2016 2:21:38 PM org.sleuthkit.autopsy.casemodule.Case doCaseChange
     [exec] INFO: Changing Case to: org.sleuthkit.autopsy.casemodule.Case@17745c3
     [exec] Jun 03, 2016 2:21:38 PM org.sleuthkit.autopsy.casemodule.Case doCaseChange
     [exec] INFO: Physical memory usage (max, total, free): 667418624, 246153216, 146216824
     [exec] JVM heap usage: init = 25165824(24576K) used = 99936392(97594K) committed = 246153216(240384K) max = 667418624(651776K), JVM non-heap usage: init = 2359296(2304K) used = 67462376(65881K) committed = 69369856(67744K) max = -1(-1K)
     [exec] Process Virtual Memory: 1,379,119,104
     [exec] Jun 03, 2016 2:21:38 PM org.sleuthkit.autopsy.keywordsearch.KeywordSearch$CaseChangeListener propertyChange
     [exec] SEVERE: Failed to open or create core for /home/tolep/Documents/aupotsy case/a/a
     [exec] org.apache.solr.client.solrj.impl.HttpSolrServer$RemoteSolrException: Expected mime type application/octet-stream but got text/html. <html>
     [exec] <head>
     [exec] <meta http-equiv="Content-Type" content="text/html;charset=ISO-8859-1"/>
     [exec] <title>Error 503 Service Unavailable</title>
     [exec] </head>
     [exec] <body>
     [exec] <h2>HTTP ERROR: 503</h2>
     [exec] <p>Problem accessing /solr/admin/cores. Reason:
     [exec] <pre>    Service Unavailable</pre></p>
     [exec] <hr /><i><small>Powered by Jetty://</small></i>
     [exec]                                                 
     [exec]                                                 
     [exec]                                                 
     [exec]                                                 
     [exec]                                                 
     [exec]                                                 
     [exec]                                                 
     [exec]                                                 
     [exec]                                                 
     [exec]                                                 
     [exec]                                                 
     [exec]                                                 
     [exec]                                                 
     [exec]                                                 
     [exec]                                                 
     [exec]                                                 
     [exec]                                                 
     [exec]                                                 
     [exec]                                                 
     [exec]                                                 
     [exec] </body>
     [exec] </html>
     [exec]
     [exec]    at org.apache.solr.client.solrj.impl.HttpSolrServer.executeMethod(HttpSolrServer.java:516)
     [exec]    at org.apache.solr.client.solrj.impl.HttpSolrServer.request(HttpSolrServer.java:210)
     [exec]    at org.apache.solr.client.solrj.impl.HttpSolrServer.request(HttpSolrServer.java:206)
     [exec]    at org.apache.solr.client.solrj.request.CoreAdminRequest.process(CoreAdminRequest.java:510)
     [exec]    at org.apache.solr.client.solrj.request.CoreAdminRequest.getStatus(CoreAdminRequest.java:558)
     [exec]    at org.sleuthkit.autopsy.keywordsearch.Server.connectToSolrServer(Server.java:1138)
     [exec]    at org.sleuthkit.autopsy.keywordsearch.Server.openCore(Server.java:711)
     [exec]    at org.sleuthkit.autopsy.keywordsearch.Server.openCoreForCase(Server.java:613)
     [exec]    at org.sleuthkit.autopsy.keywordsearch.KeywordSearch$CaseChangeListener.propertyChange(KeywordSearch.java:162)
     [exec]    at org.sleuthkit.autopsy.events.LocalEventPublisher.publish(LocalEventPublisher.java:108)
     [exec]    at org.sleuthkit.autopsy.events.AutopsyEventPublisher.publishLocally(AutopsyEventPublisher.java:149)
     [exec]    at org.sleuthkit.autopsy.casemodule.Case.changeCase(Case.java:374)
     [exec]    at org.sleuthkit.autopsy.casemodule.Case.create(Case.java:508)
     [exec]    at org.sleuthkit.autopsy.casemodule.NewCaseWizardAction$1.doInBackground(NewCaseWizardAction.java:104)
     [exec]    at org.sleuthkit.autopsy.casemodule.NewCaseWizardAction$1.doInBackground(NewCaseWizardAction.java:96)
     [exec]    at javax.swing.SwingWorker$1.call(SwingWorker.java:295)
     [exec]    at java.util.concurrent.FutureTask.run(FutureTask.java:266)
     [exec]    at javax.swing.SwingWorker.run(SwingWorker.java:334)
     [exec]    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
     [exec]    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
     [exec]    at java.lang.Thread.run(Thread.java:745)
     [exec]
     [exec] Jun 03, 2016 2:21:38 PM org.sleuthkit.autopsy.imagegallery.datamodel.DrawableDB setPragmas
     [exec] INFO: sqlite-jdbc version 3.7.8 loaded in native mode
     [exec] Jun 03, 2016 2:21:38 PM org.sleuthkit.autopsy.imagegallery.PerCaseProperties getConfigSetting
     [exec] INFO: File did not exist. Created file [Image Gallery.properties]
     [exec] Jun 03, 2016 2:21:38 PM org.sleuthkit.autopsy.ingest.IngestModuleFactoryLoader addFactory
     [exec] INFO: Found ingest module factory: name = Android Analyzer, version = 4.1.0
     [exec] Jun 03, 2016 2:21:38 PM org.sleuthkit.autopsy.ingest.IngestModuleFactoryLoader addFactory
     [exec] INFO: Found ingest module factory: name = E01 Verifier, version = 4.1.0
     [exec] Jun 03, 2016 2:21:38 PM org.sleuthkit.autopsy.ingest.IngestModuleFactoryLoader addFactory
     [exec] INFO: Found ingest module factory: name = Embedded File Extractor, version = 4.1.0
     [exec] Jun 03, 2016 2:21:38 PM org.sleuthkit.autopsy.ingest.IngestModuleFactoryLoader addFactory
     [exec] INFO: Found ingest module factory: name = Exif Parser, version = 4.1.0
     [exec] Jun 03, 2016 2:21:38 PM org.sleuthkit.autopsy.ingest.IngestModuleFactoryLoader addFactory
     [exec] INFO: Found ingest module factory: name = Extension Mismatch Detector, version = 4.1.0
     [exec] Jun 03, 2016 2:21:38 PM org.sleuthkit.autopsy.ingest.IngestModuleFactoryLoader addFactory
     [exec] INFO: Found ingest module factory: name = File Type Identification, version = 4.1.0
     [exec] Jun 03, 2016 2:21:38 PM org.sleuthkit.autopsy.ingest.IngestModuleFactoryLoader addFactory
     [exec] INFO: Found ingest module factory: name = Hash Lookup, version = 4.1.0
     [exec] Jun 03, 2016 2:21:38 PM org.sleuthkit.autopsy.ingest.IngestModuleFactoryLoader addFactory
     [exec] INFO: Found ingest module factory: name = Interesting Files Identifier, version = 4.1.0
     [exec] Jun 03, 2016 2:21:38 PM org.sleuthkit.autopsy.ingest.IngestModuleFactoryLoader addFactory
     [exec] INFO: Found ingest module factory: name = PhotoRec Carver, version = 4.1.0
     [exec] Jun 03, 2016 2:21:38 PM org.sleuthkit.autopsy.ingest.IngestModuleFactoryLoader addFactory
     [exec] INFO: Found ingest module factory: name = Virtual Machine Extractor, version = 1.0
     [exec] Jun 03, 2016 2:21:38 PM org.sleuthkit.autopsy.ingest.IngestModuleFactoryLoader addFactory
     [exec] INFO: Found ingest module factory: name = Keyword Search, version = 4.1.0
     [exec] Jun 03, 2016 2:21:38 PM org.sleuthkit.autopsy.ingest.IngestModuleFactoryLoader addFactory
     [exec] INFO: Found ingest module factory: name = Email Parser, version = 4.1.0
     [exec] Jun 03, 2016 2:21:38 PM org.sleuthkit.autopsy.ingest.IngestModuleFactoryLoader addFactory
     [exec] INFO: Found ingest module factory: name = Recent Activity, version = 4.1.0
     [exec] WARNING [org.netbeans.core.startup.InstalledFileLocatorImpl]: no such module /home/tolep/Documents/TugasAwesome/autopsy/build/cluster/update_tracking/org-sleuthkit-autopsy-python.xml at org.sleuthkit.autopsy.python.JythonModuleLoader.getInterfaceImplementations(JythonModuleLoader.java:77)
     [exec] Jun 03, 2016 2:21:38 PM org.sleuthkit.autopsy.casemodule.NewCaseWizardAction$1 done
     [exec] SEVERE: Error creating case a
     [exec] java.lang.NullPointerException
     [exec]    at org.sleuthkit.autopsy.modules.hashdatabase.HashLookupSettingsPanel.addPropertyChangeListener(HashLookupSettingsPanel.java:109)
     [exec]    at javax.swing.plaf.synth.SynthPanelUI.installListeners(SynthPanelUI.java:83)
     [exec]    at javax.swing.plaf.synth.SynthPanelUI.installUI(SynthPanelUI.java:63)
     [exec]    at javax.swing.JComponent.setUI(JComponent.java:666)
     [exec]    at javax.swing.JPanel.setUI(JPanel.java:153)
     [exec]    at javax.swing.JPanel.updateUI(JPanel.java:126)
     [exec]    at javax.swing.JPanel.<init>(JPanel.java:86)
     [exec]    at javax.swing.JPanel.<init>(JPanel.java:109)
     [exec]    at javax.swing.JPanel.<init>(JPanel.java:117)
     [exec]    at org.sleuthkit.autopsy.ingest.IngestModuleGlobalSettingsPanel.<init>(IngestModuleGlobalSettingsPanel.java:26)
     [exec]    at org.sleuthkit.autopsy.modules.hashdatabase.HashLookupSettingsPanel.<init>(HashLookupSettingsPanel.java:67)
     [exec]    at org.sleuthkit.autopsy.modules.hashdatabase.HashLookupModuleFactory.getGlobalSettingsPanel(HashLookupModuleFactory.java:103)
     [exec]    at org.sleuthkit.autopsy.ingest.IngestModuleTemplate.getGlobalSettingsPanel(IngestModuleTemplate.java:69)
     [exec]    at org.sleuthkit.autopsy.ingest.IngestJobSettingsPanel$IngestModuleModel.<init>(IngestJobSettingsPanel.java:362)
     [exec]    at org.sleuthkit.autopsy.ingest.IngestJobSettingsPanel.<init>(IngestJobSettingsPanel.java:58)
     [exec]    at org.sleuthkit.autopsy.casemodule.AddImageWizardIngestConfigPanel.<init>(AddImageWizardIngestConfigPanel.java:81)
     [exec]    at org.sleuthkit.autopsy.casemodule.AddImageWizardIterator.getPanels(AddImageWizardIterator.java:55)
     [exec]    at org.sleuthkit.autopsy.casemodule.AddImageWizardIterator.current(AddImageWizardIterator.java:104)
     [exec]    at org.openide.WizardDescriptor.updateStateOpen(WizardDescriptor.java:844)
     [exec]    at org.openide.WizardDescriptor.updateState(WizardDescriptor.java:822)
     [exec]    at org.openide.WizardDescriptor._updateState(WizardDescriptor.java:800)
     [exec]    at org.openide.WizardDescriptor.initialize(WizardDescriptor.java:475)
     [exec]    at org.openide.NotifyDescriptor.getterCalled(NotifyDescriptor.java:302)
     [exec]    at org.openide.DialogDescriptor.isModal(DialogDescriptor.java:322)
     [exec]    at org.netbeans.core.windows.services.NbDialog.<init>(NbDialog.java:67)
     [exec]    at org.netbeans.core.windows.services.DialogDisplayerImpl$1.run(DialogDisplayerImpl.java:158)
     [exec]    at org.netbeans.core.windows.services.DialogDisplayerImpl$1.run(DialogDisplayerImpl.java:119)
     [exec]    at org.netbeans.modules.openide.util.NbMutexEventProvider$Event.doEventAccess(NbMutexEventProvider.java:138)
     [exec]    at org.netbeans.modules.openide.util.NbMutexEventProvider$Event.readAccess(NbMutexEventProvider.java:98)
     [exec]    at org.netbeans.modules.openide.util.LazyMutexImplementation.readAccess(LazyMutexImplementation.java:94)
     [exec]    at org.openide.util.Mutex.readAccess(Mutex.java:218)
     [exec]    at org.netbeans.core.windows.services.DialogDisplayerImpl.createDialog(DialogDisplayerImpl.java:119)
     [exec]    at org.netbeans.core.windows.services.DialogDisplayerImpl.createDialog(DialogDisplayerImpl.java:111)
     [exec]    at org.sleuthkit.autopsy.casemodule.AddImageAction.actionPerformed(AddImageAction.java:130)
     [exec]    at org.sleuthkit.autopsy.casemodule.NewCaseWizardAction$1.done(NewCaseWizardAction.java:113)
     [exec]    at javax.swing.SwingWorker$5.run(SwingWorker.java:737)
     [exec]    at javax.swing.SwingWorker$DoSubmitAccumulativeRunnable.run(SwingWorker.java:832)
     [exec]    at sun.swing.AccumulativeRunnable.run(AccumulativeRunnable.java:112)
     [exec]    at javax.swing.SwingWorker$DoSubmitAccumulativeRunnable.actionPerformed(SwingWorker.java:842)
     [exec]    at javax.swing.Timer.fireActionPerformed(Timer.java:313)
     [exec]    at javax.swing.Timer$DoPostEvent.run(Timer.java:245)
     [exec]    at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
     [exec]    at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
     [exec]    at java.awt.EventQueue.access$500(EventQueue.java:97)
     [exec]    at java.awt.EventQueue$3.run(EventQueue.java:709)
     [exec]    at java.awt.EventQueue$3.run(EventQueue.java:703)
     [exec]    at java.security.AccessController.doPrivileged(Native Method)
     [exec]    at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
     [exec]    at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
     [exec]    at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:159)
     [exec]    at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
     [exec]    at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
     [exec]    at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
     [exec]    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
     [exec]    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
     [exec]    at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
     [exec]
     [exec] Jun 03, 2016 2:21:38 PM org.sleuthkit.autopsy.casemodule.Case deleteCaseDirectory
     [exec] INFO: Deleting case directory: /home/tolep/Documents/aupotsy case/a
afik
 
Posts: 2
Joined: Thu Jun 02, 2016 4:48 pm

Re: Building autopsy on Ubuntu 14.04.1 [Updated July 2015]

Postby marcurdy » Thu Jul 07, 2016 5:12 pm

I've gotten it to work using changes from what is posted above. Let me share.

Code: Select all
#!/bin/bash

PROXY=YES
if [ $PROXY == "YES" ]; then
  export http_proxy=http://xxx:8080
  export https_proxy=http://xxx:8080
  export ANT_OPTS="-Dhttp.proxyHost=xxx -Dhttp.proxyPort=8080"
  echo Acquire::http::proxy "$http_proxy" > /etc/apt/apt.conf
  echo Acquire::https::proxy "$http_proxy" >> /etc/apt/apt.conf
fi

workingdir=`pwd`

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java8-installer software-properties-common wget xauth git git-svn build-essential libssl-dev libbz2-dev libz-dev ant automake autoconf libtool vim python-dev gstreamer1.0

export JAVA_HOME="/usr/lib/jvm/java-8-oracle/"
export JDK_HOME="/usr/lib/jvm/java-8-oracle/"
export JRE_HOME="/usr/lib/jvm/java-8-oracle/jre/"
export TSK_HOME=$workingdir/tsk
# Download files / Git Reps
wget -c -O libewf.tar.gz https://53efc0a7187d0baa489ee347026b8278fe4020f6.googledrive.com/host/0B3fBvzttpiiSMTdoaVExWWNsRjg/libewf-20140608.tar.gz
if [ ! -d sleuthkit ]
then   
   git clone https://github.com/sleuthkit/sleuthkit.git
fi
cd sleuthkit
make clean
git pull
cd ..

if [ ! -d autopsy ]
then
   git clone https://github.com/sleuthkit/autopsy.git
fi
cd autopsy
make clean
git pull
cd ..

# Compile libewf
rm -rf libewf/
mkdir libewf
cd libewf
tar --strip-components=1 -xvzf ../libewf.tar.gz
./configure --enable-python --enable-verbose-output --enable-debug-output --prefix=$workingdir/tsk
make
make install

# Compile Sleuthkit
cd $workingdir/sleuthkit
./bootstrap
./configure --prefix=$workingdir/tsk --with-libewf=$workingdir/tsk
make
make install

# Build autopsy
mkdir -p $workingdir/tsk/bindings/java/dist
mkdir -p $workingdir/tsk/bindings/java/lib
cp $workingdir/tsk/share/java/Tsk_DataModel.jar $workingdir/tsk/bindings/java/dist/Tsk_DataModel_PostgreSQL.jar

cd $workingdir/tsk/bindings/java/lib
wget -c https://repo1.maven.org/maven2/org/xerial/sqlite-jdbc/3.8.11/sqlite-jdbc-3.8.11.jar
wget -c -O postgresql-9.4-1201-jdbc41.jar  http://central.maven.org/maven2/org/postgresql/postgresql/9.4.1208.jre7/postgresql-9.4.1208.jre7.jar
wget -c http://central.maven.org/maven2/com/mchange/c3p0/0.9.5/c3p0-0.9.5.jar
cp $workingdir/sleuthkit/bindings/java/lib/mchange-commons-java-0.2.9.jar $workingdir/tsk/bindings/java/lib/


##########################################
# RUNNING
##########################################
sudo su -  # Have to run as root to avoid a current bug

PROXY=YES
if [ $PROXY == "YES" ]; then
  export http_proxy=http://xxx:8080
  export https_proxy=http://xxx:8080
  export ANT_OPTS="-Dhttp.proxyHost=xxx -Dhttp.proxyPort=8080"
fi
export TSK_HOME=INSTALL_BASE/tsk
cd $workingdir/autopsy
ant build
ant run
marcurdy
 
Posts: 1
Joined: Thu Jul 07, 2016 5:08 pm

Re: Building autopsy on Ubuntu 14.04.1 [Updated July 2015]

Postby tatooin » Tue May 30, 2017 3:31 pm

Hello,

Not sure if anyone is still working on this topic nor if actually there is any hope to get Autopsy run under Linux in the future... But still I tried to complie autopsy using the guides upon on Linux Mint 18 (ubuntu 16.04)

Compiling works fine after getting through a couple of issues, but in the end I can compile it. But unfortunately, it doesn't run :-(

When doing "ant run" in autopsy, I get the the welcome screen then the application crashes, with the following logs:

[exec] WARNING [org.netbeans.core.startup.NbEvents]: The extension /home/vincent/autopsy/build/cluster/modules/ext/poi-3.15.jar may be multiply loaded by modules: [/home/vincent/autopsy/build/cluster/modules/org-sleuthkit-autopsy-corelibs.jar, /home/vincent/autopsy/build/cluster/modules/org-sleuthkit-autopsy-keywordsearch.jar]; see: http://www.netbeans.org/download/dev/ja ... class-path
[exec] Temp Folder for Libraries: /tmp
[exec] May 30, 2017 5:11:01 PM org.sleuthkit.autopsy.core.Installer <init>
[exec] INFO: core installer created
[exec] May 30, 2017 5:11:01 PM org.sleuthkit.autopsy.core.Installer validate
[exec] INFO: validate()
[exec] May 30, 2017 5:11:01 PM org.sleuthkit.autopsy.core.Installer validate
[exec] INFO: org.sleuthkit.autopsy.coreutils.Installer validate()
[exec] May 30, 2017 5:11:01 PM org.sleuthkit.autopsy.core.Installer validate
[exec] INFO: org.sleuthkit.autopsy.corecomponents.Installer validate()
[exec] May 30, 2017 5:11:01 PM org.sleuthkit.autopsy.core.Installer validate
[exec] INFO: org.sleuthkit.autopsy.datamodel.Installer validate()
[exec] java.lang.AssertionError: Already had dead JAR: /tmp/org-netbeans-api-progress4452867701281753354.jar
[exec] at org.netbeans.JarClassLoader$JarSource.destroy(JarClassLoader.java:700)
[exec] at org.netbeans.JarClassLoader.destroy(JarClassLoader.java:341)
[exec] at org.netbeans.StandardModule.classLoaderDown(StandardModule.java:581)
[exec] at org.netbeans.ModuleManager.enable(ModuleManager.java:1314)
[exec] at org.netbeans.ModuleManager.enable(ModuleManager.java:1170)
[exec] at org.netbeans.core.startup.ModuleList.installNew(ModuleList.java:340)
[exec] at org.netbeans.core.startup.ModuleList.trigger(ModuleList.java:276)
[exec] at org.netbeans.core.startup.ModuleSystem.restore(ModuleSystem.java:301)
[exec] at org.netbeans.core.startup.Main.getModuleSystem(Main.java:181)
[exec] at org.netbeans.core.startup.Main.getModuleSystem(Main.java:150)
[exec] at org.netbeans.core.startup.Main.start(Main.java:307)
[exec] at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:123)
[exec] at java.lang.Thread.run(Thread.java:748)
[exec] Result: 2

BUILD SUCCESSFUL
Total time: 2 minutes 4 seconds

I googled around but no luck.

Any idea or update on this thread would be much appreciated.

Thanks !
tatooin
 
Posts: 1
Joined: Tue May 30, 2017 3:27 pm

Re: Building autopsy on Ubuntu 14.04.1 [Updated July 2015]

Postby vader » Wed Sep 27, 2017 4:47 pm

Hello everybody,

I have the same error as tatooin:

I build autopsy and started it via "ant run", the loading screen appears til turning on modules...and crashes with this text:


up-to-date:

compile:
[depend] Deleted 7 out of date files in 0 seconds
[nb-javac] Compiling 5 source files to /opt/autopsy/autopsy/thunderbirdparser/build/classes
[nb-javac] warning: Supported source version 'RELEASE_6' from annotation processor 'org.netbeans.modules.openide.util.NbBundleProcessor' less than -source '1.8'
[nb-javac] warning: Supported source version 'RELEASE_7' from annotation processor 'org.netbeans.modules.openide.util.ServiceProviderProcessor' less than -source '1.8'
[nb-javac] warning: Supported source version 'RELEASE_7' from annotation processor 'org.netbeans.modules.openide.util.NamedServiceProcessor' less than -source '1.8'
[nb-javac] warning: Supported source version 'RELEASE_7' from annotation processor 'org.netbeans.modules.openide.awt.ActionProcessor' less than -source '1.8'
[nb-javac] warning: Supported source version 'RELEASE_7' from annotation processor 'org.netbeans.api.annotations.common.proc.StaticResourceProcessor' less than -source '1.8'
[nb-javac] warning: Supported source version 'RELEASE_7' from annotation processor 'org.netbeans.modules.openide.filesystems.declmime.MIMEResolverProcessor' less than -source '1.8'
[nb-javac] warning: Supported source version 'RELEASE_7' from annotation processor 'org.netbeans.modules.templates.TemplateProcessor' less than -source '1.8'
[nb-javac] warning: Supported source version 'RELEASE_7' from annotation processor 'org.netbeans.modules.openide.loaders.DataObjectFactoryProcessor' less than -source '1.8'
[nb-javac] warning: Supported source version 'RELEASE_7' from annotation processor 'org.netbeans.modules.editor.mimelookup.CreateRegistrationProcessor' less than -source '1.8'
[nb-javac] warning: Supported source version 'RELEASE_7' from annotation processor 'org.netbeans.modules.openide.windows.TopComponentProcessor' less than -source '1.8'
[nb-javac] warning: Supported source version 'RELEASE_7' from annotation processor 'org.netbeans.modules.openide.nodes.NodesAnnotationProcessor' less than -source '1.8'
[nb-javac] warning: Supported source version 'RELEASE_7' from annotation processor 'org.netbeans.modules.intent.OpenUriHandlerProcessor' less than -source '1.8'
[nb-javac] warning: Supported source version 'RELEASE_7' from annotation processor 'org.netbeans.modules.options.OptionsPanelControllerProcessor' less than -source '1.8'
[nb-javac] warning: Supported source version 'RELEASE_7' from annotation processor 'org.netbeans.modules.sendopts.OptionAnnotationProcessor' less than -source '1.8'
[nb-javac] warning: Supported source version 'RELEASE_7' from annotation processor 'org.netbeans.modules.settings.convertors.ConvertorProcessor' less than -source '1.8'
[nb-javac] warning: No processor claimed any of these annotations: javax.annotation.Generated
[nb-javac] 16 warnings

jar-prep:

jar:
[jarwithmoduleattributes] Computed OpenIDE-Module-Specification-Version: 4.0.16
[jarwithmoduleattributes] Building jar: /opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-thunderbirdparser.jar

netbeans-extra:

javahelp:

module-auto-deps:

release:
[copy] Copying 7 files to /opt/autopsy/autopsy/build/cluster

-init-startlevel:

module-xml-regular:

module-xml-autoload:

module-xml-eager:

-init-executables:

chmod-executables:

verify-class-linkage:

-validate-layers:
[xmlvalidate] 1 file(s) have been successfully validated.

-verify-apichanges:

-netbeans:

netbeans:
[genlist] Generating Auto Update information for org.sleuthkit.autopsy.thunderbirdparser

build:

-jdk-pre-preinit:

-jdk-preinit:

-jdk-warn:

-jdk-presetdef-basic:

-jdk-default:

-jdk-init:

run:

-init:

-prepare-as-app:

-prepare-as-platform:

run:
[exec] Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=128M; support was removed in 8.0
[exec] -------------------------------------------------------------------------------
[exec] >Log Session: Wednesday, September 27, 2017 6:43:29 PM CEST
[exec] >System Info:
[exec] Product Version = Autopsy 4.4.2
[exec] Operating System = Linux version 4.12.0-kali1-amd64 running on amd64
[exec] Java; VM; Vendor = 1.8.0_144; Java HotSpot(TM) 64-Bit Server VM 25.144-b01; Oracle Corporation
[exec] Runtime = Java(TM) SE Runtime Environment 1.8.0_144-b01
[exec] Java Home = /usr/lib/jvm/java-8-oracle/jre
[exec] System Locale; Encoding = en (autopsy); UTF-8
[exec] Home Directory = /root
[exec] Current Directory = /opt/autopsy/autopsy
[exec] User Directory = /opt/autopsy/autopsy/build/testuserdir
[exec] Cache Directory = /opt/autopsy/autopsy/build/testuserdir/var/cache
[exec] Installation = /opt/autopsy/autopsy/build/cluster
[exec] /opt/autopsy/autopsy/netbeans-plat/8.2/harness
[exec] /opt/autopsy/autopsy/netbeans-plat/8.2/java
[exec] /opt/autopsy/autopsy/netbeans-plat/8.2/platform
[exec] /opt/autopsy/autopsy/netbeans-plat/8.2/platform
[exec] Boot & Ext. Classpath = /usr/lib/jvm/java-8-oracle/jre/lib/resources.jar:/usr/lib/jvm/java-8-oracle/jre/lib/rt.jar:/usr/lib/jvm/java-8-oracle/jre/lib/sunrsasign.jar:/usr/lib/jvm/java-8-oracle/jre/lib/jsse.jar:/usr/lib/jvm/java-8-oracle/jre/lib/jce.jar:/usr/lib/jvm/java-8-oracle/jre/lib/charsets.jar:/usr/lib/jvm/java-8-oracle/jre/lib/jfr.jar:/usr/lib/jvm/java-8-oracle/jre/classes:/usr/lib/jvm/java-8-oracle/jre/lib/ext/sunjce_provider.jar:/usr/lib/jvm/java-8-oracle/jre/lib/ext/nashorn.jar:/usr/lib/jvm/java-8-oracle/jre/lib/ext/cldrdata.jar:/usr/lib/jvm/java-8-oracle/jre/lib/ext/dnsns.jar:/usr/lib/jvm/java-8-oracle/jre/lib/ext/sunec.jar:/usr/lib/jvm/java-8-oracle/jre/lib/ext/jfxrt.jar:/usr/lib/jvm/java-8-oracle/jre/lib/ext/sunpkcs11.jar:/usr/lib/jvm/java-8-oracle/jre/lib/ext/jaccess.jar:/usr/lib/jvm/java-8-oracle/jre/lib/ext/localedata.jar:/usr/lib/jvm/java-8-oracle/jre/lib/ext/zipfs.jar
[exec] Application Classpath = /opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/boot.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/org-openide-modules.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/org-openide-util-lookup.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/org-openide-util-ui.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/org-openide-util.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/locale/boot_ja.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/locale/boot_pt_BR.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/locale/boot_ru.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/locale/boot_zh_CN.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/locale/org-openide-modules_ja.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/locale/org-openide-modules_pt_BR.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/locale/org-openide-modules_ru.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/locale/org-openide-modules_zh_CN.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/locale/org-openide-util-lookup_ja.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/locale/org-openide-util-lookup_pt_BR.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/locale/org-openide-util-lookup_ru.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/locale/org-openide-util-lookup_zh_CN.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/locale/org-openide-util-ui_ja.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/locale/org-openide-util-ui_pt_BR.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/locale/org-openide-util-ui_ru.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/locale/org-openide-util-ui_zh_CN.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/locale/org-openide-util_ja.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/locale/org-openide-util_pt_BR.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/locale/org-openide-util_ru.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/lib/locale/org-openide-util_zh_CN.jar:/usr/lib/jvm/java-8-oracle/lib/dt.jar:/usr/lib/jvm/java-8-oracle/lib/tools.jar
[exec] Startup Classpath = /opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/org-openide-filesystems.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/core-base.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/core.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/org-openide-filesystems-compat8.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/org-netbeans-libs-asm.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/asm-all-5.0.1.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/locale/core-base_ja.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/locale/org-openide-filesystems_zh_CN.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/locale/org-openide-filesystems_pt_BR.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/locale/org-openide-filesystems-compat8_pt_BR.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/locale/core_ja.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/locale/core-base_ru.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/locale/org-openide-filesystems_ja.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/locale/org-netbeans-libs-asm_ja.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/locale/core_ru.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/locale/org-openide-filesystems-compat8_ru.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/locale/org-openide-filesystems-compat8_ja.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/locale/org-netbeans-libs-asm_ru.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/locale/core-base_pt_BR.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/locale/core-base_zh_CN.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/locale/org-netbeans-libs-asm_pt_BR.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/locale/org-netbeans-libs-asm_zh_CN.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/locale/core_pt_BR.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/locale/org-openide-filesystems-compat8_zh_CN.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/locale/org-openide-filesystems_ru.jar:/opt/autopsy/autopsy/netbeans-plat/8.2/platform/core/locale/core_zh_CN.jar:/opt/autopsy/autopsy/build/cluster/core/locale/core_autopsy.jar
[exec] -------------------------------------------------------------------------------
[exec] WARNING [org.netbeans.core.startup.InstalledFileLocatorImpl]: module org.netbeans.libs.junit4 in /opt/autopsy/autopsy/netbeans-plat/8.2/platform does not own modules/ext/junit-4.10.jar at org.netbeans.LocaleVariants.findLogicalPath(LocaleVariants.java:271)
[exec] WARNING [org.netbeans.core.startup.NbEvents]: The extension /opt/autopsy/autopsy/build/cluster/modules/ext/mchange-commons-java-0.2.9.jar may be multiply loaded by modules: [/opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-core.jar, /opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-experimental.jar]; see: http://www.netbeans.org/download/dev/ja ... class-path
[exec] WARNING [org.netbeans.core.startup.NbEvents]: The extension /opt/autopsy/autopsy/build/cluster/modules/ext/tika-core-1.14.jar may be multiply loaded by modules: [/opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-core.jar, /opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-keywordsearch.jar, /opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-experimental.jar]; see: http://www.netbeans.org/download/dev/ja ... class-path
[exec] WARNING [org.netbeans.core.startup.NbEvents]: The extension /opt/autopsy/autopsy/build/cluster/modules/ext/c3p0-0.9.5.jar may be multiply loaded by modules: [/opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-core.jar, /opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-experimental.jar]; see: http://www.netbeans.org/download/dev/ja ... class-path
[exec] WARNING [org.netbeans.core.startup.NbEvents]: The extension /opt/autopsy/autopsy/build/cluster/modules/ext/tika-core-1.14.jar may be multiply loaded by modules: [/opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-core.jar, /opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-keywordsearch.jar, /opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-experimental.jar]; see: http://www.netbeans.org/download/dev/ja ... class-path
[exec] WARNING [org.netbeans.core.startup.NbEvents]: The extension /opt/autopsy/autopsy/build/cluster/modules/ext/xmlbeans-2.6.0.jar may be multiply loaded by modules: [/opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-keywordsearch.jar, /opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-corelibs.jar]; see: http://www.netbeans.org/download/dev/ja ... class-path
[exec] WARNING [org.netbeans.core.startup.NbEvents]: The extension /opt/autopsy/autopsy/build/cluster/modules/ext/log4j-1.2.17.jar may be multiply loaded by modules: [/opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-keywordsearch.jar, /opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-corelibs.jar]; see: http://www.netbeans.org/download/dev/ja ... class-path
[exec] WARNING [org.netbeans.core.startup.NbEvents]: The extension /opt/autopsy/autopsy/build/cluster/modules/ext/commons-collections4-4.1.jar may be multiply loaded by modules: [/opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-keywordsearch.jar, /opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-corelibs.jar]; see: http://www.netbeans.org/download/dev/ja ... class-path
[exec] WARNING [org.netbeans.core.startup.NbEvents]: The extension /opt/autopsy/autopsy/build/cluster/modules/ext/commons-codec-1.10.jar may be multiply loaded by modules: [/opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-keywordsearch.jar, /opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-corelibs.jar]; see: http://www.netbeans.org/download/dev/ja ... class-path
[exec] WARNING [org.netbeans.core.startup.NbEvents]: The extension /opt/autopsy/autopsy/build/cluster/modules/ext/poi-ooxml-schemas-3.15.jar may be multiply loaded by modules: [/opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-keywordsearch.jar, /opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-corelibs.jar]; see: http://www.netbeans.org/download/dev/ja ... class-path
[exec] WARNING [org.netbeans.core.startup.NbEvents]: The extension /opt/autopsy/autopsy/build/cluster/modules/ext/poi-scratchpad-3.15.jar may be multiply loaded by modules: [/opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-keywordsearch.jar, /opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-corelibs.jar]; see: http://www.netbeans.org/download/dev/ja ... class-path
[exec] WARNING [org.netbeans.core.startup.NbEvents]: The extension /opt/autopsy/autopsy/build/cluster/modules/ext/poi-3.15.jar may be multiply loaded by modules: [/opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-keywordsearch.jar, /opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-corelibs.jar]; see: http://www.netbeans.org/download/dev/ja ... class-path
[exec] WARNING [org.netbeans.core.startup.NbEvents]: The extension /opt/autopsy/autopsy/build/cluster/modules/ext/xmpcore-5.1.2.jar may be multiply loaded by modules: [/opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-core.jar, /opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-keywordsearch.jar]; see: http://www.netbeans.org/download/dev/ja ... class-path
[exec] WARNING [org.netbeans.core.startup.NbEvents]: The extension /opt/autopsy/autopsy/build/cluster/modules/ext/poi-ooxml-3.15.jar may be multiply loaded by modules: [/opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-keywordsearch.jar, /opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-corelibs.jar]; see: http://www.netbeans.org/download/dev/ja ... class-path
[exec] WARNING [org.netbeans.core.startup.NbEvents]: The extension /opt/autopsy/autopsy/build/cluster/modules/ext/zookeeper-3.4.6.jar may be multiply loaded by modules: [/opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-core.jar, /opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-keywordsearch.jar]; see: http://www.netbeans.org/download/dev/ja ... class-path
[exec] WARNING [org.netbeans.core.startup.NbEvents]: The extension /opt/autopsy/autopsy/build/cluster/modules/ext/commons-lang-2.6.jar may be multiply loaded by modules: [/opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-keywordsearch.jar, /opt/autopsy/autopsy/build/cluster/modules/org-sleuthkit-autopsy-corelibs.jar]; see: http://www.netbeans.org/download/dev/ja ... class-path
[exec] Temp Folder for Libraries: /tmp
[exec] Sep 27, 2017 6:43:32 PM org.sleuthkit.autopsy.core.Installer <init>
[exec] INFO: core installer created
[exec] Sep 27, 2017 6:43:32 PM org.sleuthkit.autopsy.core.Installer validate
[exec] INFO: validate()
[exec] Sep 27, 2017 6:43:32 PM org.sleuthkit.autopsy.core.Installer validate
[exec] INFO: org.sleuthkit.autopsy.coreutils.Installer validate()
[exec] Sep 27, 2017 6:43:32 PM org.sleuthkit.autopsy.core.Installer validate
[exec] INFO: org.sleuthkit.autopsy.corecomponents.Installer validate()
[exec] Sep 27, 2017 6:43:32 PM org.sleuthkit.autopsy.core.Installer validate
[exec] INFO: org.sleuthkit.autopsy.datamodel.Installer validate()
[exec] java.lang.AssertionError: Already had dead JAR: /tmp/org-netbeans-api-progress3139665632007007486.jar
[exec] at org.netbeans.JarClassLoader$JarSource.destroy(JarClassLoader.java:700)
[exec] at org.netbeans.JarClassLoader.destroy(JarClassLoader.java:341)
[exec] at org.netbeans.StandardModule.classLoaderDown(StandardModule.java:581)
[exec] at org.netbeans.ModuleManager.enable(ModuleManager.java:1314)
[exec] at org.netbeans.ModuleManager.enable(ModuleManager.java:1170)
[exec] at org.netbeans.core.startup.ModuleList.installNew(ModuleList.java:340)
[exec] at org.netbeans.core.startup.ModuleList.trigger(ModuleList.java:276)
[exec] at org.netbeans.core.startup.ModuleSystem.restore(ModuleSystem.java:301)
[exec] at org.netbeans.core.startup.Main.getModuleSystem(Main.java:181)
[exec] at org.netbeans.core.startup.Main.getModuleSystem(Main.java:150)
[exec] at org.netbeans.core.startup.Main.start(Main.java:307)
[exec] at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:123)
[exec] at java.lang.Thread.run(Thread.java:748)
[exec] Result: 2

BUILD SUCCESSFUL


Any Help so far?
vader
 
Posts: 2
Joined: Wed Sep 27, 2017 4:38 pm

Building autopsy on Ubuntu 14 04 1 Updated July 2015

Postby HerbeMannABg » Fri Oct 20, 2017 3:52 pm

Thanks for the reply Harry. Do you know what the building that is currently being constructed is going to be?
HerbeMannABg
 
Posts: 2
Joined: Sat Oct 14, 2017 10:36 pm
Location: Poland

Previous

Return to Autopsy General

Who is online

Users browsing this forum: Bing [Bot] and 1 guest

cron